Mac: para ver este contenido web debe instalar el entorno de ejecución de java

El lunes un amigo vino con un Mac Air para que le hiciéramos una limpieza y optimización (si, de vez en cuando también hay que hacerlo a los Mac). Me comentó también que le salía este error cada vez que iniciaba el ordenador:

“Para ver este contenido web debe instalar el entorno de ejecución de java”.

javamac

El error te da un enlace pero por más que instalas el java de ese enlace no te soluciona el problema: sigue saliendo. Ahí os dejo la solución.

Lo que tenéis que hacer es instalar java para OSX de este enlace. Veréis que al reiniciar ya no os sale el error (por lo menos en Yosemite, supongo que cuando salgan nuevas versiones será otro Java pero buscarlo como Java para OSX).