Errores de certificados con Java. “La ejecución de esta aplicación…”

Llevamos ya dos clientes con este error. Quieren usar un certificado que funcionaba antes de Enero del 2014 y de repente salen avisos de seguridad del tipo de la imagen. O simplemente no funcionan.

trusted_expired_permission

 La razón es sencilla, Java ha decidido poner Enero del 2014 como fecha para aumentar drásticamente la seguridad y sus requisitos para poder usar ciertas aplicaciones.  Para Javas superiores a Java 1.7.0_45.Y aunque esto obviamente muy bueno, hay certificados que todavía no cumplen estos requisitos y se bloquean.

¿Sólución? Hasta que dichos certificados no se actualicen, la única solución que hemos encontrado es bajar el nivel de seguridad de Java. Si, no es óptimo…pero es que si no ciertos clientes no pueden operar.

Para ello vete a Panel de Control, elije Java (puede que tengas que irte a aplicaciones de 32 bits). En la pestaña seguridad baja el control (como un volumen), hasta abajo del todo (nivel medio).
Verás que también tienes un sitio para añadir sitios seguros o de confianza. Si añades aquí los que usas (seguridad social etc) no te hará tantas preguntas de confirmación. Eso si, bajar el nivel hay que hacerlo aunque lo añadas.

Con eso cierra y abre el navegador, vuelve a intentarlo y debería funcionar.
Más info y aquí.

 

 

Deja un comentario

Resumen de nuestra Política de Privacidad

  • Responsable: SmythSys IT Consulting SLNE.
  • Finalidad: Gestionar y moderar los comentarios.
  • Legitimación: Necesitas dar tu consentimiento para publicar un comentario.
  • Destinatarios: Tus datos se alojan en los servidores de OVH.
  • Derechos: Tienes derecho a acceder, rectificar, limitar y suprimir los datos en la dirección del responsable (en nuestra política de privacidad).

Time limit is exhausted. Please reload CAPTCHA.